Make sure your browser is updated

If you use an older browser, such as Internet Explorer 7.0 and earlier, you will need to update to a newer browser in order to view Humana websites. This is due to a newly discovered web-based security vulnerability nicknamed POODLE. It has the potential to allow compromise of computers using outdated web browsers such as Internet Explorer versions 5 and 6. The POODLE vulnerability exists in the design of the encryption protocol (SSL version 3.0), a standard technology used by older internet browsers to communicate with websites securely (HTTPS).